re = /(?:^.*?|\G[^\r\n]*?)\Ktext2/
str = 'text3 text3 text3 text3 text3 text3
text1 text2 text1 text2 text1 text2
text1 text2 text1 text2 text1 text2
text1 text2 text1 text2 text1 text2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end