import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:^|[^\\r\\n\\{]+)(?:\\{(?:[^\\{]|$)|(?:\\{{2}model\\.variable(?:\\|(?:(ein)|(phone)|(zipcode)|(currency:'':0)))?\\}{2}|$)))+$";
final String string = "Any text, punctuation (except double-{), or numb3r5 {{model.variable|phone}} is valid\n"
+ "Any text, punctuation (except double-{), or numb3r5 {{model.variable}} is valid.\n"
+ "Something about {{model.variable|phone}} or {{model.variable|zipcode}}\n"
+ "{{model.variable|zipcode}}\n"
+ "Something about {{model.variable|phone}} or {{model.variable|fax}} - shouldn't work, fax isn't an option\n"
+ "Any deviation from the format, e.g. {{model.variable|custom}} makes the entire input invalid.\n\n"
+ "(?=model\\.variable(?:\\|(?:accepted|variable|names|phone)";
final String subst = "$1$2$3 -- ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}