package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\d+(?:\.\d+)?)mcg\b`)
var str = `some text 0.25mcg some more text some text 25mcg some more text
.mcg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}