re = /'([^']+(?:'[^\s'][^']*)*)'|;([^;]+);|\S+/m
str = 'Hello \'How are you\' foo bar abc \'Strings are cool\' d b s ;12gh gh76;
Hello \'Yo what\'s up\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end