package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*[\"]*?-`)
var str = `-skipIntro -noSplash -cpuCount=7 -exThreads=7 -enableHT -malloc=tbb4malloc_bi_x64 -hugePages -maxmem=4096 -maxvram=2048 -world=empty -showScriptErrors "-mod=dwfwfaw " -dwfw`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}