use strict;
my $str = 'on join:
set the player\'s gamemode to spectator
join_player(player)
command /join [<player>]:
trigger:
if arg-1 is not set:
join_player(player)
else:
player has permission "op"
join_player(arg-1)
function reset_arena():
set all blocks within {loc1} and {loc2} to snow block';
my $regex = qr/^(?<component>(command\s?(?<head>[^:]*)):?(.*)(?<body>(?:\r?\n(?!\S).*)*))/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}