const regex = /NetBIOS\s+Domain\s+Name:\s+(?<NetBIOS_Domains_Name>.*)\s+NetBIOS\s+Computer\s+Name:\s+(?<NetBIOS_Computer_Name>.*)\s+DNS.*System\s+Time:\s+(?<System_Time>.*)\s+Authorized/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('NetBIOS\\s+Domain\\s+Name:\\s+(?<NetBIOS_Domains_Name>.*)\\s+NetBIOS\\s+Computer\\s+Name:\\s+(?<NetBIOS_Computer_Name>.*)\\s+DNS.*System\\s+Time:\\s+(?<System_Time>.*)\\s+Authorized', 'gm')
const str = `Remote Desktop Protocol: OS: Windows 10/Windows Server OS Build: 10.0.18362 Target Name: NACORP NetBIOS Domain Name: NACORP NetBIOS Computer Name: 1234ABC DNS Domain Name: na.corp.xxxxx.com System Time: 2021-12-12 22:55:40.534959 Authorized Use Only - v 041001 This system is for the use of authorized users only.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}