$re = '~^/tool_[a-z-]+(?!/public)~';
$str = '/tool_store-front/public';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);