$re = '~\d+(?!.*\d)~';
$str = 'abc 123 foo 56 yt 689';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);