$re = '/view-([\w-]+)-([\d]+)/';
$str = 'view-foundry-34-3530';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);