$re = '/(?<=\|SIP=)\d+(?:\.\d+){3}/m';
$str = '|SIP=10.111.2.234|';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);