const regex = /\s*<div\sid=\"descriptionAndDetails[\s\S]*?<div\sid=\"productDescription[\s\S]*?(<p>[\s\S]*?[\s\S]*?\s*)<\/div>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*<div\\sid=\\"descriptionAndDetails[\\s\\S]*?<div\\sid=\\"productDescription[\\s\\S]*?(<p>[\\s\\S]*?[\\s\\S]*?\\s*)<\\\/div>', 'gm')
const str = `<div id="descriptionAndDetails" class="a-section a-spacing-extra-large">
<div id="productDescription_feature_div" class="feature" data-feature-name="productDescription" data-cel-widget="productDescription_feature_div">
<div id="productDescription_feature_div" data-feature-name="productDescription" data-template-name="productDescription" class="a-row feature" data-cel-widget="productDescription_feature_div">
<div class="a-divider a-divider-section"><div class="a-divider-inner"></div></div>
<h2 class="default">
Product description
</h2>
<div id="productDescription" class="a-section a-spacing-small">
<!-- show up to 2 reviews by default -->
<p>Router bits ideal for cutting mortises Each of these router bits is constructed with M2 high speed steel to run cooler - Visit Harbor Freight Tools For More Information.
</p>
</div>
<style type="text/css">
#productDescription {
color: #333333;
word-wrap: break-word;
font-size: small;
line-height: initial;
margin: 0.5em 0px 0em 25px;
}
#productDescription_feature_div > h2.default {
color: #CC6600;
font-size: medium;
margin: 0 0 0.25em;
}
#productDescription_feature_div > h2.books {
color:#333 !important;
font-size:21px !important;
line-height: 1.3;
padding-bottom: 4px;
font-weight: normal;
margin: 0px;
}
#productDescription_feature_div > h2.softlines {
color:#333 !important;
font-size:21px !important;
line-height: 1.3;
padding-bottom: 4px;
font-weight: bold;
margin: 0px;
}
#productDescription > p, #productDescription > div, #productDescription > table {
margin: 0 0 1em 0;
}
#productDescription p {
margin: 0em 0 1em 1em;
}
#productDescription h3 {
font-weight: normal;
color: #333333;
font-size: 1.23em;
clear: left;
margin: 0.75em 0px 0.375em -15px;
}
#productDescription table {
border-collapse: inherit !important;
margin-bottom: 0;
}
#productDescription table img {
max-width: inherit !important;
}
#productDescription table td {
font-size: small;
vertical-align: inherit !important;
}
#productDescription ul li {
margin: 0 0 0 20px;
}
#productDescription ul li ul {
list-style-type: disc !important;
margin-left: 20px !important;
}
#productDescription ul ul li {
list-style-type: disc !important;
margin-left: 20px !important;
}
#productDescription > ul ul li {
list-style-type: disc !important;
}
#productDescription ul li ul li {
margin: 0 0 0 20px;
}
#productDescription .aplus p {
margin: 0 0 1em 0;
}
#productDescription small {
font-size: smaller;
}
#productDescription.prodDescWidth {
max-width: 1000px
}
</style>
<!-- Used to set table width because AUI is overriding the width attribute of the tables coming in description -->
<script type="text/javascript">
P.when('jQuery').execute(function(\$){
\$("#productDescription table").each(function() {
var width = \$(this).attr('width');
if (width) width += 'px';
else width = 'auto';
\$(this).css('width', width);
var padding = \$(this).attr('cellpadding');
if (padding) padding += 'px';
else padding = '0px';
\$(this).css('padding', padding);
});
});
</script>
</div>
</div>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}