package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((-?(\d{1,3})(\.\d+)?,\s*){2}){3,}$`)
var str = `32.3078, 64.7505,
27.6648, 81.5158,
18.2208, 66.5901,
32.3078, 64.7505,
27.6648, 81.5158,`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}