$re = '~^(?!\h*//).*~m';
$str = ' LineOfCode ...
// Other Comment
// Comments can contain every time of symbol, including "//", ".", etc.
// /**
// Another comment ...
// */
Line Of Code ...
// .,.,-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);