$re = '/(?<![^\W_])IMPORT_X_PREMIUM(?![^\W_])/m';
$str = 'CAR_NW_BMW_X3_21_01_IMPORT_X_PREMIUM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);