using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\b|_)IMPORT_X_PREMIUM(?=_|\b)";
string input = @"CAR_NW_BMW_X3_21_01_IMPORT_X_PREMIUM";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}