re = /(?!(value|id)(\":\s\"|':\su'))\b[a-fA-F\d]{32}/m
str = '"value": "ef51be4506d7d287abc8c26ea6c495f6", "u_jira_status": "", "u_quarter_closed": "", "file_hash": "ef51be4506d7d287abc8c26ea6c495f6", "escalation": "0", "upon_approval": "proceed", "correlation_id": "ef51be4506d7d287abc8c26ea6c495f6", "cyber_kill_change": "ef51be4506d7d287abc8c26ea6c495f6", "sys_id": "ef51be4506d7d287abc8c26ea6c495f6", "u_business_service": "", "destination_ip": "ef51be4506d7d287abc8c26ea6c495f6", u\'valuee\': u\'9db92f08db4f951423c87d84f39619ef\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end