$re = '/(?!^)(?<!\d)(?<!\bNo\.\s)(?<!\bQuestion\s)\d+(?!\d)/m';
$str = ' Test T860 Article No. 9712250 787
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);