package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`PHPSESSID=(.*?)(?:;|\r\n)`)
var str = `HTTP/1.1 302 Moved Temporarily Server: nginx/1.8.0 Date: Wed, 24 May 2017 08:58:57 GMT Content-Type: text/html Transfer-Encoding: chunked Connection: keep-alive X-Powered-By: PHP/5.3.10-1ubuntu3.18 Set-Cookie: PHPSESSID=jrq8446q91fv6eme2ois3lpl07; expires=Thu, 24-May-2018 08:58:57 GMT; path=/; Expires: Thu, 19 Nov 1981 08:52:00 GMT Pragma: no-cache Cache-Control: no-store, no-cache, must-revalidate Location: index.php
*`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}