$re = '/(?<=Outstanding\sBill\sfor\s)(\S+)/m';
$str = 'Outstanding Bill for xyz company for Mar 20';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);