// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s(.*)").unwrap();
let string = "England have not done this since 30 July, 1966. This remains the golden date in the country's football calendar, one that has never come close to being equalled in the subsequent 55 agonising years.
Germany were beaten by England at the knockout stage of a major tournament for the first time since that World Cup final as Gareth Southgate's side ran out deserved 2-0 winners at a joyous, nervy, celebratory Wembley.
And now the door has been pushed open a little further to give England the chance to do something else they have not done since 1966 - reach the final of a major tournament.
Germany, who have beaten England so often since that day in 1966, were overcome as Southgate earned vindication for both his tactics and his faith in captain Harry Kane, who rescued another largely average personal display with a moment of glorious release and relief when he headed home the second goal to open his account in Euro 2020.
'Nights like this allow England to dream' - Alan Shearer column
England end 55-year wait for knockout win over Germany
Who stands between England and the Euros final?
'It's a special moment for me' - Raheem Sterling
And to add to the landmarks, this was the first time England have won a match (as opposed to progressing on penalties) at the knockout stage of any European Championships. A grim statistic best erased.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}