re = /^(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\/([1-9]|1[0-9]|2[0-9]|3[0-2]|(((128|192|224|240|248|252|254)\.0\.0\.0)|(255\.(0|128|192|224|240|248|252|254)\.0\.0)|(255\.255\.(0|128|192|224|240|248|252|254)\.0)|(255\.255\.255\.(0|128|192|224|240|248|252|254))))(?<!\.0)$/m
str = '192.168.6.6/24
192.168.6.6/24
192.168.6.24/24
192.168.6.0/24
192.168.6.0/255.255.255.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end