use strict;
my $str = 'albatross_v7 g_coeffExit ExtBandsExitCoeff
albatross_v7 g_dayFilter ExtDayNotToTrade
albatross_v7 g_period ExtBandsPeriod
albatross_v7 g_tradeDuration ExtTimeWindowDuration
albatross_v7 g_tradeStartTime ExtTimeWindowStart
double_rsi g_coeffRSIFast ExtCoeffRsiFast
double_rsi g_dayFilter ExtDayNotToTrade
double_rsi g_RSIDiffLevel ExtMinRsiDiff
double_rsi g_RSIPeriod ExtSlowRsiPeriod
double_rsi g_tradeDuration ExtTimeWindowDuration
double_rsi g_tradeStartTime ExtTimeWindowStart
double_rsi g_trend ExtTrendModeFilter
double_rsi g_volatility ExtVolatilityModeFilter
double_rsi_h4_ei g_coeffRSIFast ExtCoeffRsiFast
double_rsi_h4_ei g_dayFilter ExtDayNotToTrade
double_rsi_h4_ei g_exitParameter ExtExitParameter
double_rsi_h4_ei g_exitType ExtExitType
double_rsi_h4_ei g_RSIDiffLevel ExtMinRsiDiff
double_rsi_h4_ei g_RSIPeriod ExtSlowRsiPeriod
double_rsi_h4_ei g_tradeDuration ExtTimeWindowDuration
double_rsi_h4_ei g_tradeStartTime ExtTimeWindowStart
double_rsi_h4_ei g_trend ExtTrendModeFilter
double_rsi_h4_ei g_volatility ExtVolatilityModeFilter
hook g_CoeffExit ExtExitCoeff
hook g_Cycle ExtCycleModeFilter
hook g_CycleLevel ExtCycleLevel
hook g_CyclePeriod ExtCyclePeriod
hook g_Exit ExtExitType
hook g_Order ExtOrderMode
hook g_OrderBar ExtBarsNumber
hook g_OrderPendingBar ExtOrderDeleteBar
hook g_RSIPeriod ExtRsiPeriod
hook g_Setup ExtEntrySetup
hook g_Threshold ExtRsiThreshold
hook g_Trend ExtTrendModeFilter
hook g_TrendPeriod ExtTrendPeriod
hook g_Volatility ExtVolatilityModeFilter
hook g_TradeDuration ExtTimeWindowDuration
hook g_TradeStartTime ExtTimeWindowStart
metaphor_v5 g_barsNumber ExtBarsNumber
metaphor_v5 g_coeffBarsExit ExtExitCoeffBars
metaphor_v5 g_dayFilter ExtDayNotToTrade
metaphor_v5 g_tradeDuration ExtTimeWindowDuration
metaphor_v5 g_tradeStartTime ExtTimeWindowStart
metaphor_v6 g_barsNumber ExtBarsNumber
metaphor_v6 g_BBKCPeriod ExtBbkcPeriod
metaphor_v6 g_coeffBarsExit ExtExitCoeffBars
metaphor_v6 g_dayFilter ExtDayNotToTrade
metaphor_v6 g_tradeDuration ExtTimeWindowDuration
metaphor_v6 g_tradeStartTime ExtTimeWindowStart
metaphor_v6_quick g_barsNumber ExtBarsNumber
metaphor_v6_quick g_BBKCPeriod ExtBbkcPeriod
metaphor_v6_quick g_coeffBarsExit ExtExitCoeffBars
metaphor_v6_quick g_dayFilter ExtDayNotToTrade
metaphor_v6_quick g_tradeDuration ExtTimeWindowDuration
metaphor_v6_quick g_tradeStartTime ExtTimeWindowStart
rsi_snr g_dayFilter ExtDayNotToTrade
rsi_snr g_RSIPeriod ExtRsiPeriod
rsi_snr g_SNRLevel ExtSnrLevel
rsi_snr g_SNRPeriod ExtSnrPeriod
rsi_snr g_tradeDuration ExtTimeWindowDuration
rsi_snr g_tradeStartTime ExtTimeWindowStart
rsi_snr g_trend ExtTrendModeFilter
rsi_snr g_volatility ExtVolatilityModeFilter
rsi_snr_h1_ei g_dayFilter ExtDayNotToTrade
rsi_snr_h1_ei g_exitParameter ExtExitParameter
rsi_snr_h1_ei g_exitType ExtExitType
rsi_snr_h1_ei g_RSIPeriod ExtRsiPeriod
rsi_snr_h1_ei g_SNRLevel ExtSnrLevel
rsi_snr_h1_ei g_SNRPeriod ExtSnrPeriod
rsi_snr_h1_ei g_tradeDuration ExtTimeWindowDuration
rsi_snr_h1_ei g_tradeStartTime ExtTimeWindowStart
rsi_snr_h1_ei g_trend ExtTrendModeFilter
rsi_snr_h1_ei g_volatility ExtVolatilityModeFilter
rush_v2_h1 g_counter ExtEntrySignalCounter
rush_v2_h1 g_dayFilter ExtDayNotToTrade
rush_v2_h1 g_exitBar ExtExitBar
rush_v2_h1 g_tradeDuration ExtTimeWindowDuration
rush_v2_h1 g_tradeStartTime ExtTimeWindowStart
super_smoother_ei g_dayFilter ExtDayNotToTrade
super_smoother_ei g_DiffPeriod ExtRsiPeriodDiff
super_smoother_ei g_exitParameter ExtExitParameter
super_smoother_ei g_exitType ExtExitType
super_smoother_ei g_PeriodFast ExtFastRsiPeriod
super_smoother_ei g_tradeDuration ExtTimeWindowDuration
super_smoother_ei g_tradeStartTime ExtTimeWindowStart
super_smoother_ei g_trend ExtTrendModeFilter
super_smoother_ei g_volatility ExtVolatilityModeFilter';
my $regex = qr/([\w_]+)\t([\w_]+)\t([\w_]+)/mp;
my $subst = 'update t_strategy\\n set t_strategy_parameters = replace(t_strategy_parameters, \'$2\', \'$3\')\\n where t_strategy_ea = \'$1\' and\\n t_strategy_parameters like \'%$2%\' and\\n t_strategy_version = \'1.1\';';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";