$re = '/^[A-Za-z\d$@$!%*?&]*$/m';
$str = 'asdhj89
asd@sad
7879hn
sdddddddddddddd
121312312ajk99@w$&!%*?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);