$re = '/(?<=^isLarge: [^\']*\'[^\']*) (?=[^\']*\'[^\']*$)/m';
$str = 'isLarge: \'aaaa bb-b ccc dd-d -ee\',
isLarge: aaaa bb-b ccc dd-d -ee\',
isMedium: \'aaaa bb-b ccc dd-d -ee\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);