$re = '/.*(how can (I|he)).*/mi';
$str = 'My friend is in need of help, how can I?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);