$re = '`_(\S+)\.`m';
$str = 'abcd_1.263.0.15-8zz00df.yml';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);