using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(OUT|IN) (?P<typ>\S+)\s+[s:]{0,}(?P<dest>\d*)\s*[d:]{0,}(?P<src>\d*)";
string input = @"IN MYTYPE s:12 d:12
OUT MYTYPE1 s:12
OUT MYTYPE1 d:12";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}