const regex = /(?<=>|>\s)(?:\w+[\s.-]*)+/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=>|>\\s)(?:\\w+[\\s.-]*)+', 'gmu')
const str = `<b>Тип двиг.:</b> Электрический<br/><b>Модель двиг.:</b> Y4F1<br/><b>Привод:</b> Задний`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}