package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`A(bC*)*`)
var str = `AbCCbbCbCCCCbbb`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}