const regex = /<math.*?<\/math>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<math.*?<\\\/math>', 'g')
const str = `<math xmlns=\\"http://www.w3.org/1998/Math/MathML\\"><msup><mi>b</mi><mn>1</mn></msup><mo>=</mo><mi>b</mi></math><p>Evaluating an algebraic expression means to find the value of the expression for a given value of the variable.</p><math xmlns=\\"http://www.w3.org/1998/Math/MathML\\"><mn>6</mn></math>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}