#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\+7|8)(\s|-)?(\()?[0-9]{3}(\))?(\s|-)?([0-9]{3})(\s|-)?([0-9]{2})(\s|-)?([0-9]{2})$"
Local $sString = "+79295002639" & @CRLF & _
"8 929 500 2639" & @CRLF & _
"+7 (929) 500 26-39" & @CRLF & _
"8 (929) 500 2639" & @CRLF & _
"8-9295002639" & @CRLF & _
"8478393" & @CRLF & _
"65748499" & @CRLF & _
"fkjhkhfs75768" & @CRLF & _
"+75836fjhgdlhg" & @CRLF & _
"[?:+7|8][?:\s|\-]\(?[0-9]{3}\)?[?:\s|\-][0-9]{3}[?:\s|\-][0-9]{2}[?:\s?|\-][0-9]{2}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")