package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[a-zA-Z0-9]*$`)
var str = `someordernumber`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}