package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\bFat(?:\b.*?\b)Bike\b`)
var str = `My father's fat bike is a fat tyre bike. #FatBike
My fat minibike
My father's fat, green, Schwinn bike`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}