using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*[^\s]{5}";
string input = @"Глава девятая
ПЛАВУЧИЙ ДОМ
Мне захотелось еще раз пойти взглянуть на одно место, которое я приметил посредине острова, когда его осматривал; вот мы с Джимом и отправились и скоро туда добрались, потому что остров был всего в три мили длиной и в четверть мили шириной.
Не успели мы добраться до нижнего конца острова, как начало светать. Мы заглянули в окно. Мы разглядели кровать, стол, два старых стула, и еще на полу валялось много разных вещей, а на стене висела одежда. В дальнем углу лежало что-то вроде человека. Джим окликнул:
— Эй, ты!
Но тот не пошевельнулся. Тогда и я тоже окликнул его. А потом Джим сказал:
— Он не спит — он мертвый. Ты не ходи, я сам пойду погляжу.
Он влез в окно, подошел к лежащему человеку, нагнулся, поглядел и говорит:
— Это мертвец. Да еще к тому же и голый. Его застрелили сзади. Должно быть, дня два или три, как он умер. Поди сюда, Гек, только не смотри ему в лицо — уж очень страшно.
Я совсем не стал на него смотреть. Джим прикрыл его каким-то старым тряпьем, только это было ни к чему: я и глядеть-то на него не хотел. На полу валялись старые, замасленные карты, пустые бутылки из под виски и еще две маски из черною сукна, а все стены были сплошь исписаны самыми скверными словами и разрисованы углем. На стене висели два заношенных ситцевых платья, соломенная шляпка, какие-то юбки и рубашки и мужская одежда. Мы много кое-чего снесли в челнок — могло пригодиться. На полу валялась старая соломенная шляпа, какие носят мальчишки; я ее тоже захватил. А еще там лежала бутылка из-под молока, заткнутая тряпкой, чтоб ребенку сосать. Мы бы взяли бутылку, да только она была разбита. Были еще обшарпанный старый сундук и чемодан со сломанными застежками, и тот и другой стояли раскрытые, но ничего стоящего в них не осталось. По тому, как были разбросаны вещи, видно было, что хозяева убежали второпях и не могли унести с собой все пожитки.
Нам достались: старый жестяной фонарь, большой нож без ручки, новенький карманный ножик фирмы Барлоу (такой ножик ни в одной лавке не купишь дешевле, чем за полдоллара), много сальных свечей, жестяной подсвечник, фляжка, жестяная кружка, рваное ватное одеяло, дамская сумочка с иголками, булавками, нитками, куском воска, пуговицами и прочей чепухой, топорик и гвозди, удочка потолще моего мизинца, с большущими крючками, свернутая в трубку оленья шкура, собачий ошейник, подкова, пузырьки из-под лекарств, без ярлыков; а когда мы собрались уже уходить, я нашел довольно приличную скребницу, а Джим — старый смычок от скрипки и деревянную ногу. Ремни вот только оторвались, а так совсем хорошая нога, разве только что мне она была длинна, а Джиму коротка. А другую ногу мы так и не нашли, сколько не искали.
Так что, вообще говоря, улов был неплохой. Когда мы собрались отчаливать от дома, совсем уже рассвело. Мы были на четверть мили ниже острова; я велел Джиму лечь на дно челнока и прикрыл его ватным одеялом, — а то, если б он сидел, издали было бы видно, что это негр. Я стал править к иллинойскому берегу с таким расчетом, чтобы нас отнесло на полмили вниз по течению, потом держался под самым берегом, в полосе стоячей воды. Мы вернулись на остров без всяких приключений, никого не повстречав.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}