$re = '/^(?=.{6})(?:[a-z\d]*[!$#%]){2}[a-z\d!$#%]*$/m';
$str = 'abcdef
a##def
a#cdef';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);