re = /^(\*\.)?(((?!-)[A-Za-z0-9-]{0,62}[A-Za-z0-9])\.)+((?!-)[A-Za-z0-9-]{1,62}[A-Za-z0-9])$/m
str = 'api-hello.great.world.com
https://api-hello.great.world.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end