#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*(?!.*?_.*?)(?!(?:[\d\w]+?\.)?\-[\w\d\.\-]*?)(?![\w\d]+?\-\.(?:[\d\w\.\-]+?))(?=[\w\d])(?=[\w\d\.\-]*?\.+[\w\d\.\-]*?)(?![\w\d\.\-]{254})(?!(?:\.?[\w\d\-\.]*?[\w\d\-]{64,}\.)+?)[\w\d\.\-]+?(?<![\w\d\-\.]*?\.[\d]+?)(?<=[\w\d\-]{2,})(?<![\w\d\-]{25})(\s*,\s*(?!.*?_.*?)(?!(?:[\d\w]+?\.)?\-[\w\d\.\-]*?)(?![\w\d]+?\-\.(?:[\d\w\.\-]+?))(?=[\w\d])(?=[\w\d\.\-]*?\.+[\w\d\.\-]*?)(?![\w\d\.\-]{254})(?!(?:\.?[\w\d\-\.]*?[\w\d\-]{64,}\.)+?)[\w\d\.\-]+?(?<![\w\d\-\.]*?\.[\d]+?)(?<=[\w\d\-]{2,})(?<![\w\d\-]{25}))*$"
Local $sString = "# REGEX for domains separated by comas and sapces:" & @CRLF & _
"#longest domain - 253 - add one character" & @CRLF & _
"a22bcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcde.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopdasdqrstuvwxylkjlkjlk.pl" & @CRLF & _
"#3 longest domains" & @CRLF & _
"a22bcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcde.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopdasdqrstuvwxylkjlkjlk.pl,a22bcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcde.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopdasdqrstuvwxylkjlkjlk.pl,a22bcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcde.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopdasdqrstuvwxylkjlkjlk.pl" & @CRLF & _
"#4 longest domains with spaces" & @CRLF & _
"a22bcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcde.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopdasdqrstuvwxylkjlkjlk.pl ,a22bcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcde.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopdasdqrstuvwxylkjlkjlk.pl , a22bcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcde.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopdasdqrstuvwxylkjlkjlk.pl , a22bcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcde.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopdasdqrstuvwxylkjlkjlk.pl" & @CRLF & _
"#spaces everywhere" & @CRLF & _
"al.pl , a.pl, b.com , asdf.asdf" & @CRLF & _
"" & @CRLF & _
"google.com" & @CRLF & _
"google.com,shakalaka.bu" & @CRLF & _
" shakalaka.com.pl" & @CRLF & _
"g.co" & @CRLF & _
"a.13B" & @CRLF & _
"12312412412..cor" & @CRLF & _
"xn--stackoverflow.com" & @CRLF & _
"stackoverflow.xn--com" & @CRLF & _
"xn--d1ai6ai.xn--p1ai" & @CRLF & _
"1.2.3.4.5.com , 12.34.pl" & @CRLF & _
"x.XN--VERMGENSBERATUNG-PWB" & @CRLF & _
"" & @CRLF & _
"## List of invalid domains:" & @CRLF & _
"http://google.com" & @CRLF & _
"http://www.google.com" & @CRLF & _
"dot." & @CRLF & _
"space com" & @CRLF & _
"under_score.com" & @CRLF & _
"underscore.c_om" & @CRLF & _
"-dash.com" & @CRLF & _
"dash-.com" & @CRLF & _
"sub.-dash.com" & @CRLF & _
"sub-.dash.com" & @CRLF & _
"-.com" & @CRLF & _
"-com" & @CRLF & _
".com" & @CRLF & _
"com" & @CRLF & _
"mx.gmail.com." & @CRLF & _
"mkyong.t.t.c" & @CRLF & _
"mkyong,com" & @CRLF & _
"mkyong.com/users" & @CRLF & _
"a.123" & @CRLF & _
"x.XN--VERMGENSBERATUNG-PWBB" & @CRLF & _
"abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijkk.com" & @CRLF & _
"www.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijkk.co.uk" & @CRLF & _
"abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcde.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijk.comm" & @CRLF & _
"example.c " & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")