$re = '/(?m)^\d+\+\d*@\S+/';
$str = '1345677+@gmail.com
2345678+556@gmail.com
Testing+22@gmail.com
test223+22@gmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);