package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*?\.html`)
var str = `foo.html
bar.tpl.html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}