package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\b(Fat.*?Bike)\b`)
var str = `My father's fat bike is a fat tyre bike. #FatBike`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}