re = /^(?!.+google.*search)/m
str = '[1] https://www.google.com/search?newwindow=1&sxsrf=ALeKk02MzEfbUp3jO4Np
[2] https://github.com/redis/redis-rb
[3] https://web.whatsapp.com/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end