re = /^(?:[^$]*\$){3}\s*([^$]*[^\s$])/m
str = '$command this my first text $ this is my second text $ this is my third text $ this is my fourth text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end