$re = '/[!=]=|[<>]|(?:(?![=!]=)[^<>])+/';
$str = 'Text1==text2<text3><More here!=';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);