using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<w-block-content[^<>]*>\s*<span[^<>]*>\s*<div[^<>]*>([^]*?)<\/div>\s*<\/span>\s*<\/w-block-content>";
string input = @"</tr>
<td>
<div draggable=""true"" class=""source master draggable-box wysiwyg-block"" data-block-type=""master"" data-block-id=""96e80afb-afa0-4e46-bfb7-34b80da76112"" style=""opacity: 1;"">
<w-block-content data-block-content-id=""96e80afb-afa0-4e46-bfb7-34b80da76112""><span class=""source-block-tooltip"">
<div>
Další master<br><div><b>Master č. 2</b> </div><br>
</div>
</span></w-block-content>
</div>
</td>
</tr>
</tr>
<td>
<div draggable=""true"" class=""source master draggable-box wysiwyg-block"" data-block-type=""master"" data-block-id=""96e80afb-afa0-4e46-bfb7-34b80da76112"" style=""opacity: 1;"">
<w-block-content data-block-content-id=""96e80afb-afa0-4e46-bfb7-34b80da76112""><span class=""source-block-tooltip"">
<div>
Další master<br><b>Master č. 2</b><br>
</div>
</span></w-block-content>
</div>
</td>
</tr>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}