$re = '/https://www\.example\.com/(?!de_de(?:/|$))[a-z_]+/m';
$str = 'https://www.example.com/int_en
https://www.example.com/int_de
https://www.example.com/de_de
https://www.example.com/be_de
https://www.example.com/de_en
https://www.example.com/fr_en
https://www.example.com/fr_fr
https://www.example.com/gb_en
https://www.example.com/us_en
https://www.example.com/ch_de
https://www.example.com/ch_it
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);