# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"{\"pm10\":\s+(\d+(\.\d+)?)[^}]*}]"
test_str = "[{\"pm10\": 10.1, \"pm25\": 4.7, \"time\": \"15.11.2019 13:01:49\"}, {\"pm25\": 4.5, \"pm10\": 11.2, \"time\": \"15.11.2019 13:07:21\"}, {\"pm10\": 10.1, \"pm25\": 4.5, \"time\": \"15.11.2019 13:12:54\"}, {\"pm25\": 4.3, \"pm10\": 8.7, \"time\": \"15.11.2019 13:18:26\"}, {\"pm10\": 12.3, \"pm25\": 5.0, \"time\": \"15.11.2019 13:23:58\"}, {\"pm25\": 4.8, \"pm10\": 9.9, \"time\": \"15.11.2019 13:29:31\"}, {\"pm10\": 9.7, \"pm25\": 4.4, \"time\": \"15.11.2019 13:35:03\"}, {\"pm25\": 4.5, \"pm10\": 9.8, \"time\": \"15.11.2019 13:40:35\"}, {\"pm10\": 9.1, \"pm25\": 5.0, \"time\": \"15.11.2019 13:46:08\"}, {\"pm25\": 4.7, \"pm10\": 10.8, \"time\": \"15.11.2019 13:51:40\"}, {\"pm10\": 9.6, \"pm25\": 4.5, \"time\": \"15.11.2019 13:57:13\"}, {\"pm25\": 4.8, \"pm10\": 10.2, \"time\": \"15.11.2019 14:02:45\"}, {\"pm10\": 12.0, \"pm25\": 5.0, \"time\": \"15.11.2019 14:08:17\"}, {\"pm25\": 5.0, \"pm10\": 11.0, \"time\": \"15.11.2019 14:13:50\"}, {\"pm10\": 11.9, \"pm25\": 4.6, \"time\": \"15.11.2019 14:19:22\"}, {\"pm25\": 5.3, \"pm10\": 11.1, \"time\": \"15.11.2019 14:24:54\"}, {\"pm10\": 12.5, \"pm25\": 4.8, \"time\": \"15.11.2019 14:30:27\"}, {\"pm25\": 5.7, \"pm10\": 12.9, \"time\": \"15.11.2019 14:35:59\"}, {\"pm10\": 10.7, \"pm25\": 5.1, \"time\": \"15.11.2019 14:41:32\"}, {\"pm25\": 5.4, \"pm10\": 13.8, \"time\": \"15.11.2019 14:47:04\"}, {\"pm10\": 12.6, \"pm25\": 5.7, \"time\": \"15.11.2019 14:52:36\"}, {\"pm25\": 6.2, \"pm10\": 14.2, \"time\": \"15.11.2019 15:10:09\"}, {\"pm10\": 13.7, \"pm25\": 6.0, \"time\": \"15.11.2019 15:15:41\"}, {\"pm25\": 7.0, \"pm10\": 15.6, \"time\": \"15.11.2019 15:16:58\"}, {\"pm10\": 15.2, \"pm25\": 7.2, \"time\": \"15.11.2019 15:22:28\"}, {\"pm25\": 7.0, \"pm10\": 15.8, \"time\": \"15.11.2019 16:51:10\"}, {\"pm10\": 14.2, \"pm25\": 6.7, \"time\": \"15.11.2019 16:56:42\"}, {\"pm25\": 7.7, \"pm10\": 17.2, \"time\": \"15.11.2019 16:58:32\"}, {\"pm10\": 16.2, \"pm25\": 6.6, \"time\": \"15.11.2019 17:04:04\"}, {\"pm25\": 7.3, \"pm10\": 16.4, \"time\": \"15.11.2019 17:09:37\"}, {\"pm10\": 15.6, \"pm25\": 6.9, \"time\": \"15.11.2019 17:15:09\"}, {\"pm25\": 6.6, \"pm10\": 14.7, \"time\": \"15.11.2019 17:20:42\"}, {\"pm10\": 14.9, \"pm25\": 6.5, \"time\": \"15.11.2019 17:26:14\"}, {\"pm25\": 6.8, \"pm10\": 14.8, \"time\": \"15.11.2019 17:31:46\"}, {\"pm10\": 13.7, \"pm25\": 6.4, \"time\": \"15.11.2019 17:37:19\"}, {\"pm25\": 7.1, \"pm10\": 16.0, \"time\": \"15.11.2019 17:50:58\"}, {\"pm10\": 15.0, \"pm25\": 6.8, \"time\": \"15.11.2019 17:52:08\"}, {\"pm25\": 7.2, \"pm10\": 16.0, \"time\": \"15.11.2019 17:57:40\"}, {\"pm10\": 15.7, \"pm25\": 7.1, \"time\": \"15.11.2019 18:03:13\"}, {\"pm25\": 6.9, \"pm10\": 14.9, \"time\": \"15.11.2019 18:08:45\"}, {\"pm10\": 18.6, \"pm25\": 7.4, \"time\": \"15.11.2019 18:14:17\"}, {\"pm25\": 8.0, \"pm10\": 18.6, \"time\": \"15.11.2019 18:19:50\"}, {\"pm10\": 19.3, \"pm25\": 7.9, \"time\": \"15.11.2019 18:25:22\"}, {\"pm25\": 8.2, \"pm10\": 19.8, \"time\": \"15.11.2019 18:30:54\"}, {\"pm10\": 17.5, \"pm25\": 8.0, \"time\": \"15.11.2019 18:36:27\"}, {\"pm25\": 7.6, \"pm10\": 16.4, \"time\": \"15.11.2019 18:41:59\"}, {\"pm10\": 16.7, \"pm25\": 7.9, \"time\": \"15.11.2019 18:47:31\"}, {\"pm25\": 7.4, \"pm10\": 16.8, \"time\": \"15.11.2019 18:53:04\"}, {\"pm10\": 17.6, \"pm25\": 7.4, \"time\": \"15.11.2019 18:58:36\"}, {\"pm25\": 7.2, \"pm10\": 20.3, \"time\": \"15.11.2019 19:04:09\"}, {\"pm10\": 17.3, \"pm25\": 7.3, \"time\": \"15.11.2019 19:09:41\"}, {\"pm25\": 8.5, \"pm10\": 18.3, \"time\": \"15.11.2019 19:15:13\"}, {\"pm10\": 20.2, \"pm25\": 8.8, \"time\": \"15.11.2019 19:20:46\"}, {\"pm25\": 9.0, \"pm10\": 21.4, \"time\": \"15.11.2019 19:26:18\"}, {\"pm10\": 20.7, \"pm25\": 9.3, \"time\": \"15.11.2019 19:31:50\"}, {\"pm25\": 8.5, \"pm10\": 17.0, \"time\": \"15.11.2019 19:37:23\"}, {\"pm10\": 18.1, \"pm25\": 8.2, \"time\": \"15.11.2019 19:42:55\"}, {\"pm25\": 7.9, \"pm10\": 17.9, \"time\": \"15.11.2019 19:48:28\"}, {\"pm10\": 16.4, \"pm25\": 7.7, \"time\": \"15.11.2019 19:54:00\"}, {\"pm25\": 8.0, \"pm10\": 16.6, \"time\": \"15.11.2019 19:59:32\"}, {\"pm10\": 15.7, \"pm25\": 7.9, \"time\": \"15.11.2019 20:05:05\"}, {\"pm25\": 7.0, \"pm10\": 15.0, \"time\": \"15.11.2019 20:10:37\"}, {\"pm10\": 14.6, \"pm25\": 6.7, \"time\": \"15.11.2019 20:16:09\"}, {\"pm25\": 7.1, \"pm10\": 12.7, \"time\": \"15.11.2019 20:21:42\"}, {\"pm10\": 16.6, \"pm25\": 7.3, \"time\": \"15.11.2019 20:27:14\"}, {\"pm25\": 6.4, \"pm10\": 14.0, \"time\": \"15.11.2019 20:32:47\"}, {\"pm10\": 15.2, \"pm25\": 6.7, \"time\": \"15.11.2019 20:38:19\"}, {\"pm25\": 6.8, \"pm10\": 12.8, \"time\": \"15.11.2019 20:43:51\"}, {\"pm10\": 12.7, \"pm25\": 6.6, \"time\": \"15.11.2019 20:49:24\"}, {\"pm25\": 6.9, \"pm10\": 12.2, \"time\": \"15.11.2019 20:54:56\"}, {\"pm10\": 11.2, \"pm25\": 6.4, \"time\": \"15.11.2019 21:00:28\"}, {\"pm25\": 5.6, \"pm10\": 11.5, \"time\": \"15.11.2019 21:06:01\"}, {\"pm10\": 11.2, \"pm25\": 5.6, \"time\": \"15.11.2019 21:11:33\"}, {\"pm25\": 2.4, \"pm10\": 5.2, \"time\": \"16.11.2019 08:50:54\"}, {\"pm10\": 5.2, \"pm25\": 2.3, \"time\": \"16.11.2019 08:56:27\"}, {\"pm25\": 2.7, \"pm10\": 8.2, \"time\": \"16.11.2019 09:01:59\"}, {\"pm10\": 4.7, \"pm25\": 2.1, \"time\": \"16.11.2019 09:07:32\"}, {\"pm25\": 2.0, \"pm10\": 5.1, \"time\": \"16.11.2019 09:13:04\"}, {\"pm10\": 4.6, \"pm25\": 2.1, \"time\": \"16.11.2019 09:18:36\"}, {\"pm25\": 5.0, \"pm10\": 11.7, \"time\": \"16.11.2019 13:16:41\"}, {\"pm10\": 10.1, \"pm25\": 4.6, \"time\": \"16.11.2019 13:22:11\"}, {\"pm25\": 7.3, \"pm10\": 17.2, \"time\": \"16.11.2019 15:36:53\"}, {\"pm10\": 13.6, \"pm25\": 6.2, \"time\": \"16.11.2019 15:42:25\"}, {\"pm25\": 7.7, \"pm10\": 15.4, \"time\": \"16.11.2019 17:02:49\"}, {\"pm10\": 14.5, \"pm25\": 7.1, \"time\": \"16.11.2019 17:08:22\"}, {\"pm25\": 8.5, \"pm10\": 15.7, \"time\": \"16.11.2019 17:38:24\"}, {\"pm10\": 15.2, \"pm25\": 7.8, \"time\": \"16.11.2019 17:43:57\"}, {\"pm25\": 8.2, \"pm10\": 19.6, \"time\": \"16.11.2019 17:49:29\"}, {\"pm10\": 16.5, \"pm25\": 7.7, \"time\": \"16.11.2019 17:55:01\"}, {\"pm25\": 8.1, \"pm10\": 13.4, \"time\": \"16.11.2019 20:46:43\"}, {\"pm10\": 14.4, \"pm25\": 8.4, \"time\": \"16.11.2019 20:52:15\"}, {\"pm25\": 7.2, \"pm10\": 14.3, \"time\": \"16.11.2019 20:57:48\"}, {\"pm10\": 12.7, \"pm25\": 7.4, \"time\": \"16.11.2019 21:03:20\"}, {\"pm25\": 7.0, \"pm10\": 11.1, \"time\": \"16.11.2019 21:08:52\"}, {\"pm10\": 11.4, \"pm25\": 6.4, \"time\": \"16.11.2019 21:14:25\"}, {\"pm25\": 6.1, \"pm10\": 9.2, \"time\": \"16.11.2019 21:38:13\"}, {\"pm10\": 10.7, \"pm25\": 6.0, \"time\": \"16.11.2019 21:43:45\"}, {\"pm25\": 6.4, \"pm10\": 10.0, \"time\": \"16.11.2019 21:49:18\"}, {\"pm10\": 9.7, \"pm25\": 6.1, \"time\": \"16.11.2019 21:54:50\"}, {\"pm25\": 5.9, \"pm10\": 8.2, \"time\": \"16.11.2019 22:00:22\"}, {\"pm10\": 9.5, \"pm25\": 6.3, \"time\": \"16.11.2019 22:05:55\"}]"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.