package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)value=(.+?) ,`)
var str = `isLogIn=true; Max-Age=400; Path=/; Expires=Wed, 25 Sep 2019 17:46:30 GMT, value=qasde% , client=retail
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}