$re = '/(https?|ftp):///m';
$str = 'http://baidu.com
https://baidu.com
ftp://192.168.1.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);