$re = '/(?<=Elevation: )\d+\.\d ft/m';
$str = 'Random text
Elevation: 23.0 ft
MoreRandomText';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);